Page 1 of 1

Focusrite Saffire 6 USB

PostPosted: Mon Mar 09, 2015 7:45 pm
by push-pop
Hey all,

I'm trying to get Audio I/O working with Touch Designer and by usb interface (Focusrite Saffire 6)


Output seems to be working and input to the card is definitely working. (Can monitor and record in Audacity.) But I can't seem to get input to work within Touch.

Other devices i.e. microphones work no problem and seem to just work.

I've tried ASIO and DirectSound. It picks up the ASIO driver and I can select the inputs, but I get nothing.

Lights are blinking on the interface so I know I'm getting a signal...

Any ideas?? I attached what I'm looking at.

EDIT: It's working with DirectSound but not ASIO

Re: Focusrite Saffire 6 USB

PostPosted: Mon Mar 09, 2015 9:34 pm
by elburz
Try deselecting the channels and see if it's coming in off different channels other than 1 and 2?

Re: Focusrite Saffire 6 USB

PostPosted: Tue Mar 10, 2015 8:37 am
by push-pop
Nah even with the default Channels: *

I get nothing...

Re: Focusrite Saffire 6 USB

PostPosted: Mon Sep 28, 2015 4:44 pm
by jmt4zj
This might not be much help but TD works great with my Focusrite Liquid Saffire 56 over firewire with the latest experimental version. Best of luck!

Re: Focusrite Saffire 6 USB

PostPosted: Sun Apr 14, 2019 9:18 am
by greenpattern
Man I have same usb 6 safire, i think its too old card there is something not working right, after messing with it for 2 hours i figured out its good wast of my time.

Re: Focusrite Saffire 6 USB

PostPosted: Wed May 08, 2019 1:56 am
by ben
I would try, uninstalling drivers and reinstall.
Then I would try a USB2.0 post if your computer has one, USB3 is finicky on some audio devices, especially old ones made for USB2.