Login | Register 
FEATURES
APPLICATIONS
DOWNLOADS
EDUCATION
BLOG
WIKI
FORUM
STORE

FIXED:Collision messages are inaccurate

Report bugs so we can squash them!

FIXED:Collision messages are inaccurate

Postby spaghetti » Thu Feb 14, 2019 5:40 pm

Using TouchDesigner Experimental 2019.11370 on macOS

The collision messages coming out of the Bullet Solver CHOP are never accurate. It either misses a collision, activates when there is no collision, or all objects send a collision message at the same time. When the current frame rate goes lower, it gets even more inaccurate. Doubling the simulation sample rate doesn't seem to improve it either. Lots of flashing on and off of all objects at once.
spaghetti
 
Posts: 37
Joined: Sat Oct 08, 2016 5:28 pm

Re: Collision messages are inaccurate

Postby eric.b » Fri Feb 15, 2019 6:55 pm

Do you have the same problem with the collision callback on the Bullet Solver COMP, or is it just the CHOP?
User avatar
eric.b
Staff
 
Posts: 113
Joined: Mon Jun 13, 2016 3:53 pm
Location: Toronto

Re: Collision messages are inaccurate

Postby Alexkrut » Thu Feb 28, 2019 5:33 pm

Same happening for me, espesially on high velocities. So it seems, that collision happening in betweed frames... Callbacks works better (but not 100% all collisions), but chop sometimes missing a lot of a collision.
Alexkrut
 
Posts: 20
Joined: Mon Jan 05, 2015 7:24 pm

Re: Collision messages are inaccurate

Postby eric.b » Tue Jul 16, 2019 12:51 pm

Sorry for the delay on this. I've fixed the issues with inaccurate collision values on the Bullet Solver CHOP. These fixes will be in the next official build, 2019.17170+.

If you're still having problems with collision values in the next build, post an example here and I'll address it.
User avatar
eric.b
Staff
 
Posts: 113
Joined: Mon Jun 13, 2016 3:53 pm
Location: Toronto

Re: FIXED:Collision messages are inaccurate

Postby spaghetti » Fri Jul 26, 2019 7:08 pm

Thank you man. Right on time, I am hosting a workshop on this at TDSummit
spaghetti
 
Posts: 37
Joined: Sat Oct 08, 2016 5:28 pm


Return to Bugs

Who is online

Users browsing this forum: No registered users and 11 guests